Old Parrot Community

Community portal of the Parrot Project.

You are not logged in.

#1 2017-06-18 07:10:57

Unconfirmed Member
Registered: 2017-06-18
Posts: 2

Persistence won't persist

So, I have had this issue for quite a while, First with kali, now with parrot. I double checked the code and copied to paste. When booting, it says "Device or resource busy" on the partition that has the file persistence.conf . I think it has an issue with connecting in general, so I tried going into gparted and setting the flag for boot. But this doesn't help any. I just need a way to have it read the partition in general, any answers?


#2 2017-06-19 10:15:39

Community Member
From: Ireland
Registered: 2017-02-12
Posts: 172

Re: Persistence won't persist

Install Parrot with dd on the USB. and after that, with gparted create an ext4 partition on the un assigned space. you dont need to give any special flag to that partition.
Then make sure that you create the persistence.conf file with out spaces or any wrong codification. A simple:

mount /dev/sdb3 /mnt/my_usb
echo "/ union" > /mnt/my_usb/persistence.conf

Should be enough.

Also make sure that your partition label is persistence also.

That should work..


#3 2017-06-22 04:16:06

Unconfirmed Member
Registered: 2017-06-18
Posts: 2

Re: Persistence won't persist

I already tried that. thats the reason I'm posting is because the conventional method isn't working


#4 2017-06-22 04:50:22

From: USA
Registered: 2017-02-11
Posts: 297

Re: Persistence won't persist


-Jeff Szydel

*Parrot Ambassador   *Social Groups Manager   *Helpdesk   *Wiki Editor   
*Parrot Telegram Group Administrator   *Parrot Community Administrator


Board footer

Powered by FluxBB

Design by Klocek.